generator: Some String parameters should be OptString (RHBZ#501894).
[libguestfs.git] / fish / Makefile.am
index 1652c54..3dc1a1e 100644 (file)
@@ -31,7 +31,8 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
-       rc_protocol.x
+       rc_protocol.x \
+       guestfish.pod
 
 guestfish_SOURCES = \
        $(generator_built) \
@@ -43,7 +44,9 @@ guestfish_SOURCES = \
        fish.h \
        glob.c \
        lcd.c \
+       man.c \
        more.c \
+       prep.c \
        rc.c \
        reopen.c \
        tilde.c \
@@ -58,6 +61,7 @@ guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)