Fix rpcgen post-processing for out-of-tree builds
[libguestfs.git] / fish / Makefile.am
index dd0625d..16a29b0 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -139,7 +139,7 @@ if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x
        rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       sed 's,\.\./\(\.\./\)*fish,.,' < $@-t > $@-t2
        rm $@-t
        mv $@-t2 $@