build: Centralize all POD manipulation in 'podwrapper.sh' script.
[libguestfs.git] / fish / Makefile.am
index 89cc4ec..01ed59c 100644 (file)
@@ -17,6 +17,8 @@
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfish.pod
+
 bin_PROGRAMS = guestfish
 
 generator_built = \
@@ -46,6 +48,7 @@ EXTRA_DIST = \
 # other guestfish files.
 SHARED_SOURCE_FILES = \
        inspect.c \
+       keys.c \
        options.h \
        options.c \
        virt.c
@@ -62,6 +65,7 @@ guestfish_SOURCES = \
        fish.c \
        fish.h \
        glob.c \
+       help.c \
        hexedit.c \
        lcd.c \
        man.c \
@@ -101,11 +105,9 @@ guestfish_CFLAGS = \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-       $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 guestfish_LDADD = \
-       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
        $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
 
 # Make guestfish use the convenience libraries.
@@ -130,25 +132,23 @@ endif
 
 guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
        $(top_srcdir)/relink-static.sh \
-       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
+       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) $(LIBVIRT_LIBS) $(LIBXML2_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
 
 # Manual page.
-# guestfish-actions.pod and guestfish-commands.pod are autogenerated.
-# There is no include mechanism for POD, so we have to do it by hand.
 
 man_MANS = guestfish.1
-
-guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
-       sed \
-         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
-         -e '/@FISH_COMMANDS@/rguestfish-commands.pod' -e 's/@FISH_COMMANDS@//' \
-         < $< | \
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestfish" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
+noinst_DATA = $(top_builddir)/html/guestfish.1.html
+
+guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
+
+stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man guestfish.1 \
+         --html $(top_builddir)/html/guestfish.1.html \
+         --insert guestfish-actions.pod:@ACTIONS@ \
+         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         $<
+       touch $@
 
 # Bash completion script.