Enable deprecation warnings on all C programs.
[libguestfs.git] / fish / Makefile.am
index 87f937c..69540dd 100644 (file)
@@ -115,6 +115,7 @@ cmds_gperf.c: cmds_gperf.gperf
        mv $@-t $@
 
 guestfish_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \