extra tests: Absolute path for 'run' command.
[libguestfs.git] / extratests / Makefile.am
index 739f1c2..b055d65 100644 (file)
@@ -32,7 +32,7 @@ VG = valgrind \
        --leak-check=full \
        --error-exitcode=119 \
        --suppressions=$(abs_srcdir)/suppressions
-RUN_VG = ../run $(VG)
+RUN_VG = $(abs_top_builddir)/run $(VG)
 
 export LIBVIRT_DEFAULT_URI = \
        qemu+unix:///system?socket=/var/run/libvirt/libvirt-sock-ro
@@ -43,10 +43,15 @@ GUESTS = $(shell virsh -c $(LIBVIRT_DEFAULT_URI) list --all | \
                 awk '{print $$2}')
 
 extra-tests: \
+       test-capitests \
        test-tools-null \
        test-tools-internal \
-       test-tools-real \
-       test-ocaml
+       test-df-real \
+       test-filesystems-real \
+       test-inspector-real \
+       test-ocaml \
+       test-resize \
+       test-sparsify
 
 # Null invocations of the basic tools shouldn't leak memory.
 test-tools-null:
@@ -80,32 +85,46 @@ test-tools-internal:
        $(RUN_VG) ../inspector/virt-inspector -a ../images/windows.img >/dev/null
 
 # Invocations of tools on real images shouldn't leak memory.
-test-tools-real:
+test-df-real:
        $(RUN_VG) virt-df >/dev/null
        $(RUN_VG) virt-df -h >/dev/null
+
+test-filesystems-real:
        @for g in $(GUESTS); do \
-         echo $(RUN_VG) ../inspector/virt-inspector -d $$g; \
-         $(RUN_VG) ../inspector/virt-inspector -d $$g > /dev/null; \
+         echo $(RUN_VG) ../cat/virt-filesystems -d $$g --all --long -h --uuid; \
+         $(RUN_VG) ../cat/virt-filesystems -d $$g --all --long -h --uuid > /dev/null; \
          r=$$?; \
          if [ $$r -ne 0 ]; then exit $$r; fi; \
        done
+
+test-inspector-real:
        @for g in $(GUESTS); do \
-         echo $(RUN_VG) ../cat/virt-filesystems -d $$g --all --long -h --uuid; \
-         $(RUN_VG) ../cat/virt-filesystems -d $$g --all --long -h --uuid > /dev/null; \
+         echo $(RUN_VG) ../inspector/virt-inspector -d $$g; \
+         $(RUN_VG) ../inspector/virt-inspector -d $$g > /dev/null; \
          r=$$?; \
          if [ $$r -ne 0 ]; then exit $$r; fi; \
        done
 
+# Run virt-resize tests under valgrind.
+test-resize:
+       $(MAKE) -C ../resize VG="$(VG)" check
+
+# Run virt-sparsify tests under valgrind.
+test-sparsify:
+       $(MAKE) -C ../sparsify VG="$(VG)" check
+
 # XXX Not tested:
 # ../clone/virt-sysprep
 # ../edit/virt-edit
 # ../edit/virt-edit -e
 # ../fuse/guestmount
-# ../resize/virt-resize (OCaml)
-# ../sparsify/virt-sparsify (OCaml)
 # ../tools/virt-win-reg (Perl)
 # ../tools/virt-make-fs (Perl)
 
+# Run capitests under valgrind.
+test-capitests:
+       $(MAKE) -C ../capitests VG="$(RUN_VG)" check
+
 # Test OCaml bindings under valgrind.
 test-ocaml:
        $(MAKE) -C ../ocaml VG="$(VG)" check