extra tests: Run C API tests under valgrind.
[libguestfs.git] / extratests / Makefile.am
index 739f1c2..3449ca7 100644 (file)
@@ -46,6 +46,7 @@ extra-tests: \
        test-tools-null \
        test-tools-internal \
        test-tools-real \
+       test-capitests \
        test-ocaml
 
 # Null invocations of the basic tools shouldn't leak memory.
@@ -106,6 +107,10 @@ test-tools-real:
 # ../tools/virt-win-reg (Perl)
 # ../tools/virt-make-fs (Perl)
 
+# Run capitests under valgrind.
+test-capitests:
+       $(MAKE) -C ../capitests VG="$(RUN_VG)" check
+
 # Test OCaml bindings under valgrind.
 test-ocaml:
        $(MAKE) -C ../ocaml VG="$(VG)" check