tests: Rename capitests -> tests/c-api.
[libguestfs.git] / extratests / Makefile.am
index bf6b3f9..0b4e20e 100644 (file)
@@ -22,6 +22,7 @@
 #   - the disks of these guests are accessible by the current user
 #     (tip: add yourself to the 'disk' group)
 #   - valgrind
+#   - libtool
 #
 # These tests may fail for reasons which aren't necessarily real problems.
 #
@@ -68,7 +69,8 @@ GUESTS = $(shell virsh -c $(LIBVIRT_DEFAULT_URI) list --all | \
                 awk '{print $$2}')
 
 extra-tests: \
-       test-capitests \
+       test-prerequisites \
+       test-c-api \
        test-tools-null \
        test-tools-internal \
        test-df-real \
@@ -78,6 +80,16 @@ extra-tests: \
        test-resize \
        test-sparsify
 
+test-prerequisites:
+       @libtool --help >/dev/null 2>&1 || { \
+         echo "extra-tests: libtool is not installed"; \
+         exit 1; \
+       }
+       @valgrind --help >/dev/null 2>&1 || { \
+         echo "extra-tests: valgrind is not installed"; \
+         exit 1; \
+       }
+
 # Null invocations of the basic tools shouldn't leak memory.
 test-tools-null:
        $(RUN_VG) ../fish/guestfish -N part exit
@@ -138,9 +150,9 @@ test-resize:
 test-sparsify:
        $(MAKE) -C ../sparsify VG="$(VG)" check
 
-# Run capitests under valgrind.
-test-capitests:
-       $(MAKE) -C ../capitests VG="$(RUN_VG)" check
+# Run c-api tests under valgrind.
+test-c-api:
+       $(MAKE) -C ../tests/c-api VG="$(RUN_VG)" check
 
 # Test OCaml bindings under valgrind.
 test-ocaml: