tests: Rename capitests -> tests/c-api.
[libguestfs.git] / extratests / Makefile.am
index b055d65..0b4e20e 100644 (file)
 #   - the disks of these guests are accessible by the current user
 #     (tip: add yourself to the 'disk' group)
 #   - valgrind
+#   - libtool
 #
 # These tests may fail for reasons which aren't necessarily real problems.
+#
+# XXX Not tested:
+#
+# ../clone/virt-sysprep
+#   - hard to test because it's a shell script
+#
+# ../edit/virt-edit
+#
+# Perl bindings
+# ../edit/virt-edit -e
+# ../tools/virt-win-reg (Perl)
+# ../tools/virt-make-fs (Perl)
+#   - hard because Perl doesn't cooperate by freeing memory
+#
+# Python bindings
+#   - as for Perl
+#
+# Ruby bindings
+#   - these look feasible to test using valgrind
+#
+# Java bindings
+#
+# ../fuse/guestmount
+#   - hard to test because guestmount forks into the background, and
+#     if valgrind reports errors it doesn't stop the test shell script
 
 EXTRA_DIST = suppressions
 
@@ -43,7 +69,8 @@ GUESTS = $(shell virsh -c $(LIBVIRT_DEFAULT_URI) list --all | \
                 awk '{print $$2}')
 
 extra-tests: \
-       test-capitests \
+       test-prerequisites \
+       test-c-api \
        test-tools-null \
        test-tools-internal \
        test-df-real \
@@ -53,6 +80,16 @@ extra-tests: \
        test-resize \
        test-sparsify
 
+test-prerequisites:
+       @libtool --help >/dev/null 2>&1 || { \
+         echo "extra-tests: libtool is not installed"; \
+         exit 1; \
+       }
+       @valgrind --help >/dev/null 2>&1 || { \
+         echo "extra-tests: valgrind is not installed"; \
+         exit 1; \
+       }
+
 # Null invocations of the basic tools shouldn't leak memory.
 test-tools-null:
        $(RUN_VG) ../fish/guestfish -N part exit
@@ -113,17 +150,9 @@ test-resize:
 test-sparsify:
        $(MAKE) -C ../sparsify VG="$(VG)" check
 
-# XXX Not tested:
-# ../clone/virt-sysprep
-# ../edit/virt-edit
-# ../edit/virt-edit -e
-# ../fuse/guestmount
-# ../tools/virt-win-reg (Perl)
-# ../tools/virt-make-fs (Perl)
-
-# Run capitests under valgrind.
-test-capitests:
-       $(MAKE) -C ../capitests VG="$(RUN_VG)" check
+# Run c-api tests under valgrind.
+test-c-api:
+       $(MAKE) -C ../tests/c-api VG="$(RUN_VG)" check
 
 # Test OCaml bindings under valgrind.
 test-ocaml: