Add guestfs-testing(1) man page.
[libguestfs.git] / examples / Makefile.am
index c84285f..d898c99 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 EXTRA_DIST = \
        LICENSE \
        guestfs-examples.pod \
-       guestfs-recipes.pod
+       guestfs-recipes.pod \
+       guestfs-testing.pod
 
 CLEANFILES = \
        stamp-guestfs-examples.pod \
-       stamp-guestfs-recipes.pod
+       stamp-guestfs-recipes.pod \
+       stamp-guestfs-testing.pod
 
 noinst_PROGRAMS = create_disk inspect_vm
 if HAVE_HIVEX
@@ -57,14 +59,16 @@ virt_dhcp_address_LDADD = \
 
 man_MANS = \
        guestfs-examples.3 \
-       guestfs-recipes.1
+       guestfs-recipes.1 \
+       guestfs-testing.1
 noinst_DATA = \
        $(top_builddir)/html/guestfs-examples.3.html \
-       $(top_builddir)/html/guestfs-recipes.1.html
+       $(top_builddir)/html/guestfs-recipes.1.html \
+       $(top_builddir)/html/guestfs-testing.1.html
 
 guestfs-examples.3 $(top_builddir)/html/guestfs-examples.3.html: stamp-guestfs-examples.pod
 
-stamp-guestfs-examples.pod: $(srcdir)/guestfs-examples.pod $(srcdir)/create_disk.c $(srcdir)/inspect_vm.c
+stamp-guestfs-examples.pod: guestfs-examples.pod create_disk.c inspect_vm.c
        $(top_builddir)/podwrapper.sh \
          --section 3 \
          --man guestfs-examples.3 \
@@ -76,10 +80,20 @@ stamp-guestfs-examples.pod: $(srcdir)/guestfs-examples.pod $(srcdir)/create_disk
 
 guestfs-recipes.1 $(top_builddir)/html/guestfs-recipes.1.html: stamp-guestfs-recipes.pod
 
-stamp-guestfs-recipes.pod: $(builddir)/guestfs-recipes.pod create_disk.c inspect_vm.c
+stamp-guestfs-recipes.pod: guestfs-recipes.pod
        $(top_builddir)/podwrapper.sh \
          --section 1 \
          --man guestfs-recipes.1 \
          --html $(top_builddir)/html/guestfs-recipes.1.html \
          $<
        touch $@
+
+guestfs-testing.1 $(top_builddir)/html/guestfs-testing.1.html: stamp-guestfs-testing.pod
+
+stamp-guestfs-testing.pod: guestfs-testing.pod
+       $(top_builddir)/podwrapper.sh \
+         --section 1 \
+         --man guestfs-testing.1 \
+         --html $(top_builddir)/html/guestfs-testing.1.html \
+         $<
+       touch $@