out-of-tree build: fix documentation generation
[libguestfs.git] / examples / Makefile.am
index b8a2ffe..c84285f 100644 (file)
@@ -64,20 +64,20 @@ noinst_DATA = \
 
 guestfs-examples.3 $(top_builddir)/html/guestfs-examples.3.html: stamp-guestfs-examples.pod
 
-stamp-guestfs-examples.pod: guestfs-examples.pod create_disk.c inspect_vm.c
-       $(top_srcdir)/podwrapper.sh \
+stamp-guestfs-examples.pod: $(srcdir)/guestfs-examples.pod $(srcdir)/create_disk.c $(srcdir)/inspect_vm.c
+       $(top_builddir)/podwrapper.sh \
          --section 3 \
          --man guestfs-examples.3 \
          --html $(top_builddir)/html/guestfs-examples.3.html \
-         --verbatim create_disk.c:@EXAMPLE1@ \
-         --verbatim inspect_vm.c:@EXAMPLE2@ \
+         --verbatim $(srcdir)/create_disk.c:@EXAMPLE1@ \
+         --verbatim $(srcdir)/inspect_vm.c:@EXAMPLE2@ \
          $<
        touch $@
 
 guestfs-recipes.1 $(top_builddir)/html/guestfs-recipes.1.html: stamp-guestfs-recipes.pod
 
-stamp-guestfs-recipes.pod: guestfs-recipes.pod create_disk.c inspect_vm.c
-       $(top_srcdir)/podwrapper.sh \
+stamp-guestfs-recipes.pod: $(builddir)/guestfs-recipes.pod create_disk.c inspect_vm.c
+       $(top_builddir)/podwrapper.sh \
          --section 1 \
          --man guestfs-recipes.1 \
          --html $(top_builddir)/html/guestfs-recipes.1.html \