Version 1.11.19.
[libguestfs.git] / examples / Makefile.am
index 00a5267..b8a2ffe 100644 (file)
 
 EXTRA_DIST = \
        LICENSE \
-       guestfs-examples.pod
+       guestfs-examples.pod \
+       guestfs-recipes.pod
 
-CLEANFILES = stamp-guestfs-examples.pod
+CLEANFILES = \
+       stamp-guestfs-examples.pod \
+       stamp-guestfs-recipes.pod
 
 noinst_PROGRAMS = create_disk inspect_vm
 if HAVE_HIVEX
@@ -28,6 +31,7 @@ endif
 
 create_disk_SOURCES = create_disk.c
 create_disk_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 create_disk_LDADD = \
@@ -35,6 +39,7 @@ create_disk_LDADD = \
 
 inspect_vm_SOURCES = inspect_vm.c
 inspect_vm_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 inspect_vm_LDADD = \
@@ -42,6 +47,7 @@ inspect_vm_LDADD = \
 
 virt_dhcp_address_SOURCES = virt-dhcp-address.c
 virt_dhcp_address_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS) \
        $(HIVEX_CFLAGS)
@@ -49,8 +55,12 @@ virt_dhcp_address_LDADD = \
        $(HIVEX_LIBS) \
        $(top_builddir)/src/libguestfs.la
 
-man_MANS = guestfs-examples.3
-noinst_DATA = $(top_builddir)/html/guestfs-examples.3.html
+man_MANS = \
+       guestfs-examples.3 \
+       guestfs-recipes.1
+noinst_DATA = \
+       $(top_builddir)/html/guestfs-examples.3.html \
+       $(top_builddir)/html/guestfs-recipes.1.html
 
 guestfs-examples.3 $(top_builddir)/html/guestfs-examples.3.html: stamp-guestfs-examples.pod
 
@@ -63,3 +73,13 @@ stamp-guestfs-examples.pod: guestfs-examples.pod create_disk.c inspect_vm.c
          --verbatim inspect_vm.c:@EXAMPLE2@ \
          $<
        touch $@
+
+guestfs-recipes.1 $(top_builddir)/html/guestfs-recipes.1.html: stamp-guestfs-recipes.pod
+
+stamp-guestfs-recipes.pod: guestfs-recipes.pod create_disk.c inspect_vm.c
+       $(top_srcdir)/podwrapper.sh \
+         --section 1 \
+         --man guestfs-recipes.1 \
+         --html $(top_builddir)/html/guestfs-recipes.1.html \
+         $<
+       touch $@