Update FSF address.
[libguestfs.git] / examples / Makefile.am
index dee0849..8d6accd 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 EXTRA_DIST = \
        LICENSE \
-       guestfs-examples.pod
+       guestfs-examples.pod \
+       guestfs-recipes.pod
 
-CLEANFILES = stamp-guestfs-examples.pod
+CLEANFILES = \
+       stamp-guestfs-examples.pod \
+       stamp-guestfs-recipes.pod
 
 noinst_PROGRAMS = create_disk inspect_vm
+if HAVE_HIVEX
+noinst_PROGRAMS += virt-dhcp-address
+endif
 
 create_disk_SOURCES = create_disk.c
 create_disk_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 create_disk_LDADD = \
@@ -32,22 +39,47 @@ create_disk_LDADD = \
 
 inspect_vm_SOURCES = inspect_vm.c
 inspect_vm_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 inspect_vm_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
-man_MANS = guestfs-examples.3
-noinst_DATA = $(top_builddir)/html/guestfs-examples.3.html
+virt_dhcp_address_SOURCES = virt-dhcp-address.c
+virt_dhcp_address_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS) \
+       $(HIVEX_CFLAGS)
+virt_dhcp_address_LDADD = \
+       $(HIVEX_LIBS) \
+       $(top_builddir)/src/libguestfs.la
+
+man_MANS = \
+       guestfs-examples.3 \
+       guestfs-recipes.1
+noinst_DATA = \
+       $(top_builddir)/html/guestfs-examples.3.html \
+       $(top_builddir)/html/guestfs-recipes.1.html
 
 guestfs-examples.3 $(top_builddir)/html/guestfs-examples.3.html: stamp-guestfs-examples.pod
 
 stamp-guestfs-examples.pod: guestfs-examples.pod create_disk.c inspect_vm.c
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --section 3 \
          --man guestfs-examples.3 \
          --html $(top_builddir)/html/guestfs-examples.3.html \
-         --verbatim create_disk.c:@EXAMPLE1@ \
-         --verbatim inspect_vm.c:@EXAMPLE2@ \
+         --verbatim $(srcdir)/create_disk.c:@EXAMPLE1@ \
+         --verbatim $(srcdir)/inspect_vm.c:@EXAMPLE2@ \
+         $<
+       touch $@
+
+guestfs-recipes.1 $(top_builddir)/html/guestfs-recipes.1.html: stamp-guestfs-recipes.pod
+
+stamp-guestfs-recipes.pod: guestfs-recipes.pod
+       $(top_builddir)/podwrapper.sh \
+         --section 1 \
+         --man guestfs-recipes.1 \
+         --html $(top_builddir)/html/guestfs-recipes.1.html \
          $<
        touch $@