docs: Standard C examples, and guestfs-examples(3) man page.
[libguestfs.git] / examples / Makefile.am
index 04bbe5e..7f7d8f7 100644 (file)
@@ -1,17 +1,47 @@
-# libguestfs examples
+# libguestfs C examples
+# Copyright (C) 2010 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-include $(top_srcdir)/subdir-rules.mk
+EXTRA_DIST = \
+       LICENSE \
+       guestfs-examples.pod
 
-noinst_PROGRAMS = hello to-xml
+CLEANFILES = stamp-guestfs-examples.pod
 
-hello_SOURCES = hello.c
-hello_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
-hello_LDADD = $(top_builddir)/src/libguestfs.la
+noinst_PROGRAMS = create_disk inspect_vm
 
-to_xml_SOURCES = to-xml.c
-to_xml_CPPFLAGS = \
-  -I$(top_srcdir)/gnulib/lib \
-  -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
-to_xml_LDADD = $(top_builddir)/src/libguestfs.la
+create_disk_SOURCES = create_disk.c
+create_disk_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
+create_disk_LDADD = $(top_builddir)/src/libguestfs.la
 
-CLEANFILES = $(noinst_PROGRAMS)
+inspect_vm_SOURCES = inspect_vm.c
+inspect_vm_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
+inspect_vm_LDADD = $(top_builddir)/src/libguestfs.la
+
+man_MANS = guestfs-examples.3
+noinst_DATA = $(top_builddir)/html/guestfs-examples.3.html
+
+guestfs-examples.3 $(top_builddir)/html/guestfs-examples.3.html: stamp-guestfs-examples.pod
+
+stamp-guestfs-examples.pod: guestfs-examples.pod create_disk.c inspect_vm.c
+       $(top_srcdir)/podwrapper.sh \
+         --section 3 \
+         --man guestfs-examples.3 \
+         --html $(top_builddir)/html/guestfs-examples.3.html \
+         --verbatim create_disk.c:@EXAMPLE1@ \
+         --verbatim inspect_vm.c:@EXAMPLE2@ \
+         $<
+       touch $@