fuse: Skip guestmount test if setfacl is not installed.
[libguestfs.git] / edit / Makefile.am
index 5195b51..eac2877 100644 (file)
@@ -38,6 +38,7 @@ virt_edit_SOURCES = \
        virt-edit.c
 
 virt_edit_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -57,7 +58,7 @@ noinst_DATA = $(top_builddir)/html/virt-edit.1.html
 virt-edit.1 $(top_builddir)/html/virt-edit.1.html: stamp-virt-edit.pod
 
 stamp-virt-edit.pod: virt-edit.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-edit.1 \
          --html $(top_builddir)/html/virt-edit.1.html \
          $<
@@ -70,6 +71,7 @@ random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
 TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 TESTS = test-virt-edit.sh