build: Set TMPDIR for local testing.
[libguestfs.git] / edit / Makefile.am
index 8489ebb..e33b33c 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs virt-edit
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 EXTRA_DIST = \
-       run-edit-locally
+       test-virt-edit.sh \
+       virt-edit.pod
 
-if HAVE_EDIT
+CLEANFILES = stamp-virt-edit.pod
 
-bin_SCRIPTS = virt-edit
-man_MANS = virt-edit.1
+bin_PROGRAMS = virt-edit
+
+SHARED_SOURCE_FILES = \
+       ../fish/config.c \
+       ../fish/inspect.c \
+       ../fish/keys.c \
+       ../fish/options.h \
+       ../fish/options.c \
+       ../fish/virt.c
+
+virt_edit_SOURCES = \
+       $(SHARED_SOURCE_FILES) \
+       virt-edit.c
+
+virt_edit_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+       $(LIBCONFIG_CFLAGS) \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+virt_edit_LDADD = \
+       $(LIBCONFIG_LIBS) \
+       $(top_builddir)/src/libguestfs.la \
+       ../gnulib/lib/libgnu.la
 
+# Manual pages and HTML files for the website.
+man_MANS = virt-edit.1
 noinst_DATA = $(top_builddir)/html/virt-edit.1.html
 
-virt-edit.1: virt-edit
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
-
-$(top_builddir)/html/virt-edit.1.html: virt-edit
-       mkdir -p $(top_builddir)/html
-       cd $(top_builddir) && pod2html \
-         --css 'pod.css' \
-         --title 'virt-edit, edit a file in a virtual machine' \
-         --htmldir html \
-         --outfile html/virt-edit.1.html \
-         edit/$<
-
-endif
+virt-edit.1 $(top_builddir)/html/virt-edit.1.html: stamp-virt-edit.pod
+
+stamp-virt-edit.pod: virt-edit.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-edit.1 \
+         --html $(top_builddir)/html/virt-edit.1.html \
+         $<
+       touch $@
+
+# Tests.
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+       MALLOC_PERTURB_=$(random_val) \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
+
+TESTS = test-virt-edit.sh