Use AC_GNU_SOURCE in daemon. Don't need _GNU_SOURCE in C files any more.
[libguestfs.git] / daemon / configure.ac
index 59ed51e..e0ff7ce 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-AC_INIT([libguestfs-daemon],[0.2])
+AC_INIT([libguestfs-daemon],[1.0.0])
 AM_INIT_AUTOMAKE
 
+AC_CONFIG_MACRO_DIR([m4])
+
 dnl If the user specified --enable-32bit, then force the C compiler
 dnl to build 32 bit binaries (gcc -m32).
 AC_ARG_ENABLE([32bit],
@@ -25,6 +27,15 @@ AC_ARG_ENABLE([32bit],
   [export CC="gcc -m32"],
   [enable_32bit=no])
 
+dnl Enable 'debug' command.
+AC_ARG_ENABLE([debug-command],
+  [AS_HELP_STRING([--enable-debug-command], [enable the 'debug' command])],
+  [AC_DEFINE_UNQUOTED([ENABLE_DEBUG_COMMAND],[1],[Enable the 'debug' command])],
+  [])
+
+dnl For strchrnul(3), asprintf(3), futimens(2) and getline(3).
+AC_GNU_SOURCE
+
 dnl Check for basic C environment.
 AC_PROG_CC
 AC_PROG_INSTALL
@@ -35,6 +46,14 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AC_PROG_CC_C_O
 
+dnl Check for Augeas.
+AC_CHECK_LIB([augeas],[aug_match],,[
+       AC_MSG_ERROR([Augeas library not found])
+       ])
+
+dnl Check for functions not available in earlier versions of Augeas.
+AC_CHECK_FUNC([aug_load aug_defvar aug_defnode])
+
 dnl Check for XDR library.
 AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
        AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])