daemon/Win32: Use gnulib pread module.
[libguestfs.git] / daemon / configure.ac
index c6d9d98..d1a9b0f 100644 (file)
@@ -124,6 +124,12 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AM_PROG_CC_C_O
 
+dnl If the host is Windows, define _WIN32_WINNT to a suitable value.
+AC_CANONICAL_HOST
+case $host in
+     *mingw*|*cygwin*|*win32*) CFLAGS="$CFLAGS -D_WIN32_WINNT=0x0500" ;;
+esac
+
 dnl Check support for 64 bit file offsets.
 AC_SYS_LARGEFILE
 
@@ -173,15 +179,18 @@ AC_CHECK_FUNCS([\
         lsetxattr \
         lremovexattr \
         mknod \
+        posix_fallocate \
         removexattr \
-        setxattr])
+        setxattr \
+        sync])
 
 dnl Headers.
 AC_CHECK_HEADERS([\
-       attr/xattr.h \
-       printf.h \
-       sys/inotify.h \
-       sys/xattr.h])
+        attr/xattr.h \
+        printf.h \
+        sys/inotify.h \
+        sys/xattr.h \
+        windows.h])
 
 dnl For modified printf, we need glibc either (old-style)
 dnl register_printf_function or (new-style) register_printf_specifier.