debug: Add 'debug progress' command.
[libguestfs.git] / daemon / configure.ac
index d1a9b0f..b9ad70b 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs-daemon
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -31,12 +31,6 @@ AC_ARG_ENABLE([32bit],
   [export CC="gcc -m32"],
   [enable_32bit=no])
 
-dnl Enable 'debug' command.
-AC_ARG_ENABLE([debug-command],
-  [AS_HELP_STRING([--enable-debug-command], [enable the 'debug' command])],
-  [AC_DEFINE_UNQUOTED([ENABLE_DEBUG_COMMAND],[1],[Enable the 'debug' command])],
-  [])
-
 dnl Enable packet dumps when in verbose mode.  This generates lots
 dnl of debug info, only useful for people debugging the RPC mechanism.
 AC_ARG_ENABLE([packet-dump],
@@ -170,8 +164,9 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
 
 dnl Functions which may not be available in older distributions.
 AC_CHECK_FUNCS([\
-        futimens \
         getxattr \
+        htonl \
+        htons \
         inotify_init1 \
         lgetxattr \
         listxattr \
@@ -179,9 +174,13 @@ AC_CHECK_FUNCS([\
         lsetxattr \
         lremovexattr \
         mknod \
+        ntohl \
+        ntohs \
         posix_fallocate \
+        realpath \
         removexattr \
         setxattr \
+        statvfs \
         sync])
 
 dnl Headers.
@@ -189,6 +188,7 @@ AC_CHECK_HEADERS([\
         attr/xattr.h \
         printf.h \
         sys/inotify.h \
+        sys/statvfs.h \
         sys/xattr.h \
         windows.h])