Add support for zerofree command.
[libguestfs.git] / daemon / configure.ac
index e8aebc9..a91db6d 100644 (file)
@@ -33,6 +33,9 @@ AC_ARG_ENABLE([debug-command],
   [AC_DEFINE_UNQUOTED([ENABLE_DEBUG_COMMAND],[1],[Enable the 'debug' command])],
   [])
 
+dnl For strchrnul(3), asprintf(3), futimens(2) and getline(3).
+AC_GNU_SOURCE
+
 dnl Check for basic C environment.
 AC_PROG_CC
 AC_PROG_INSTALL
@@ -43,19 +46,25 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AC_PROG_CC_C_O
 
-dnl Check for Augeas.
-AC_CHECK_LIB([augeas],[aug_match],,[
-       AC_MSG_ERROR([Augeas library not found])
-       ])
-
-dnl Check for functions not available in earlier versions of Augeas.
-AC_CHECK_FUNC([aug_load aug_defvar aug_defnode])
+dnl Check for Augeas (now optional).
+AC_CHECK_LIB([augeas],[aug_match],[
+       LIBS="-laugeas $LIBS"
+       have_augeas=yes
+       dnl Check for functions not available in earlier versions of Augeas.
+       AC_CHECK_FUNCS([aug_load aug_defvar aug_defnode])
+       ],[have_augeas=no])
+if test "x$have_augeas" = "xyes"; then
+       AC_DEFINE([HAVE_AUGEAS],[1],[Define to 1 if you have Augeas])
+fi
 
 dnl Check for XDR library.
 AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
        AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
        ])
 
+dnl Functions which may not be available in older distributions.
+AC_CHECK_FUNCS([futimens])
+
 dnl Produce output files.
 AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_FILES([Makefile])