Update TODO.
[libguestfs.git] / daemon / configure.ac
index bd0bdbe..7a6c04a 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs-daemon
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -31,12 +31,6 @@ AC_ARG_ENABLE([32bit],
   [export CC="gcc -m32"],
   [enable_32bit=no])
 
-dnl Enable 'debug' command.
-AC_ARG_ENABLE([debug-command],
-  [AS_HELP_STRING([--enable-debug-command], [enable the 'debug' command])],
-  [AC_DEFINE_UNQUOTED([ENABLE_DEBUG_COMMAND],[1],[Enable the 'debug' command])],
-  [])
-
 dnl Enable packet dumps when in verbose mode.  This generates lots
 dnl of debug info, only useful for people debugging the RPC mechanism.
 AC_ARG_ENABLE([packet-dump],
@@ -45,6 +39,16 @@ AC_ARG_ENABLE([packet-dump],
         [AC_DEFINE([ENABLE_PACKET_DUMP],[1],[Enable packet dumps in verbose mode.])],
         [])
 
+dnl Install the daemon (for libguestfs live service)
+AC_MSG_CHECKING([if we should install the daemon])
+AC_ARG_ENABLE([install-daemon],
+        [AS_HELP_STRING([--enable-install-daemon],
+          [enable installing the daemon under $sbindir @<:@default=no@:>@])],
+        [],
+        [enable_install_daemon=no])
+AM_CONDITIONAL([INSTALL_DAEMON],[test "x$enable_install_daemon" = "xyes"])
+AC_MSG_RESULT([$enable_install_daemon])
+
 dnl For strchrnul(3), asprintf(3), futimens(2) and getline(3).
 AC_GNU_SOURCE
 
@@ -95,6 +99,10 @@ if test "$gl_gcc_warnings" = yes; then
   # ?? -Wstrict-overflow
   nw="$nw -Wunsafe-loop-optimizations" # just a warning that an optimization
                                     # was not possible, safe to ignore
+  nw="$nw -Wlong-long"              # Allow long long since it's required
+                                    # by Python, Ruby and xstrtoll.
+  nw="$nw -Wstack-protector"        # Don't warn about stack-protector
+                                    # failures (seen on Ubuntu).
 
   gl_MANYWARN_ALL_GCC([ws])
   gl_MANYWARN_COMPLEMENT([ws], [$ws], [$nw])
@@ -141,6 +149,11 @@ AC_STRUCT_ST_BLOCKS
 AC_CHECK_MEMBER([struct stat.st_blksize],[
         AC_DEFINE([HAVE_STRUCT_STAT_ST_BLKSIZE],[1],[Define to 1 if 'st_blksize' is a member of 'struct stat'])])
 
+dnl Check for gperf.
+AC_CHECK_PROG([GPERF],[gperf],[gperf],[no])
+test "x$GPERF" = "xno" &&
+     AC_MSG_ERROR([gperf must be installed])
+
 dnl Check for Augeas (now optional).
 AC_CHECK_LIB([augeas],[aug_match],[
         LIBS="-laugeas $LIBS"
@@ -171,6 +184,8 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
 dnl Functions which may not be available in older distributions.
 AC_CHECK_FUNCS([\
         getxattr \
+        htonl \
+        htons \
         inotify_init1 \
         lgetxattr \
         listxattr \
@@ -178,9 +193,14 @@ AC_CHECK_FUNCS([\
         lsetxattr \
         lremovexattr \
         mknod \
+        ntohl \
+        ntohs \
         posix_fallocate \
+        realpath \
         removexattr \
+        setitimer \
         setxattr \
+        sigaction \
         statvfs \
         sync])