build: enable automake's silent rules option
[libguestfs.git] / daemon / configure.ac
index 126e125..43e331b 100644 (file)
@@ -19,6 +19,9 @@ AC_INIT([libguestfs-daemon],[1.0.0])
 AC_CONFIG_AUX_DIR([build-aux])
 AM_INIT_AUTOMAKE([foreign])
 
+m4_ifndef([AM_SILENT_RULES], [m4_define([AM_SILENT_RULES],[])])
+AM_SILENT_RULES([yes]) # make --enable-silent-rules the default.
+
 AC_CONFIG_MACRO_DIR([m4])
 
 dnl If the user specified --enable-32bit, then force the C compiler
@@ -67,7 +70,7 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
         ])
 
 dnl Functions which may not be available in older distributions.
-AC_CHECK_FUNCS([futimens listxattr llistxattr getxattr lgetxattr setxattr lsetxattr removexattr lremovexattr])
+AC_CHECK_FUNCS([futimens listxattr llistxattr getxattr lgetxattr setxattr lsetxattr removexattr lremovexattr inotify_init1])
 
 dnl For modified printf, we need glibc either (old-style)
 dnl register_printf_function or (new-style) register_printf_specifier.