Make it possible to build in a separate directory
[libguestfs.git] / daemon / configure.ac
index 26fefe5..238532e 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-AC_INIT([libguestfs-daemon],[0.1])
-AM_INIT_AUTOMAKE
-
-dnl Make sure the user has created the link to nfs-utils source.
-if ! test -e $srcdir/nfs-utils \
-    -o -f $srcdir/nfs-utils/utils/nfsd/nfsd.c; then
-  AC_MSG_ERROR([$srcdir/nfs-utils must be a symlink to the unpacked nfs-utils sources.
-See the README file for more information.])
-fi
+AC_INIT([libguestfs-daemon],[1.0.0])
+AM_INIT_AUTOMAKE([foreign])
+
+AC_CONFIG_MACRO_DIR([m4])
 
 dnl If the user specified --enable-32bit, then force the C compiler
 dnl to build 32 bit binaries (gcc -m32).
 AC_ARG_ENABLE([32bit],
   [AS_HELP_STRING([--enable-32bit], [build 32 bit binaries (gcc -m32)])],
-  [CC="gcc -m32"],
+  [export CC="gcc -m32"],
   [enable_32bit=no])
 
+dnl Enable 'debug' command.
+AC_ARG_ENABLE([debug-command],
+  [AS_HELP_STRING([--enable-debug-command], [enable the 'debug' command])],
+  [AC_DEFINE_UNQUOTED([ENABLE_DEBUG_COMMAND],[1],[Enable the 'debug' command])],
+  [])
+
+dnl For strchrnul(3), asprintf(3), futimens(2) and getline(3).
+AC_GNU_SOURCE
+
 dnl Check for basic C environment.
 AC_PROG_CC
 AC_PROG_INSTALL
@@ -40,15 +44,26 @@ AC_PROG_CPP
 AC_C_PROTOTYPES
 test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
-AC_PROG_CC_C_O
+AM_PROG_CC_C_O
+
+dnl Check for Augeas (now optional).
+AC_CHECK_LIB([augeas],[aug_match],[
+       LIBS="-laugeas $LIBS"
+       have_augeas=yes
+       dnl Check for functions not available in earlier versions of Augeas.
+       AC_CHECK_FUNCS([aug_load aug_defvar aug_defnode])
+       ],[have_augeas=no])
+if test "x$have_augeas" = "xyes"; then
+       AC_DEFINE([HAVE_AUGEAS],[1],[Define to 1 if you have Augeas])
+fi
 
 dnl Check for XDR library.
 AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
        AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
        ])
 
-dnl Run in subdirs.
-AC_CONFIG_SUBDIRS([nfs-utils])
+dnl Functions which may not be available in older distributions.
+AC_CHECK_FUNCS([futimens])
 
 dnl Produce output files.
 AC_CONFIG_HEADERS([config.h])