daemon/Win32: provide htonl, htons, ntohl, ntohs functions.
[libguestfs.git] / daemon / configure.ac
index c6d9d98..1d335b1 100644 (file)
@@ -124,6 +124,12 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AM_PROG_CC_C_O
 
+dnl If the host is Windows, define _WIN32_WINNT to a suitable value.
+AC_CANONICAL_HOST
+case $host in
+     *mingw*|*cygwin*|*win32*) CFLAGS="$CFLAGS -D_WIN32_WINNT=0x0500" ;;
+esac
+
 dnl Check support for 64 bit file offsets.
 AC_SYS_LARGEFILE
 
@@ -164,8 +170,9 @@ AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
 
 dnl Functions which may not be available in older distributions.
 AC_CHECK_FUNCS([\
-        futimens \
         getxattr \
+        htonl \
+        htons \
         inotify_init1 \
         lgetxattr \
         listxattr \
@@ -173,15 +180,22 @@ AC_CHECK_FUNCS([\
         lsetxattr \
         lremovexattr \
         mknod \
+        ntohl \
+        ntohs \
+        posix_fallocate \
         removexattr \
-        setxattr])
+        setxattr \
+        statvfs \
+        sync])
 
 dnl Headers.
 AC_CHECK_HEADERS([\
-       attr/xattr.h \
-       printf.h \
-       sys/inotify.h \
-       sys/xattr.h])
+        attr/xattr.h \
+        printf.h \
+        sys/inotify.h \
+        sys/statvfs.h \
+        sys/xattr.h \
+        windows.h])
 
 dnl For modified printf, we need glibc either (old-style)
 dnl register_printf_function or (new-style) register_printf_specifier.