Add 'checksum' command.
[libguestfs.git] / daemon / configure.ac
index 406594a..0bd37b0 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-AC_INIT([libguestfs-daemon],[0.1])
+AC_INIT([libguestfs-daemon],[1.0.0])
 AM_INIT_AUTOMAKE
 
-dnl Make sure the user has created the link to nfs-utils source.
-if ! test -e $srcdir/nfs-utils \
-    -o -f $srcdir/nfs-utils/utils/nfsd/nfsd.c; then
-  AC_MSG_ERROR([$srcdir/nfs-utils must be a symlink to the unpacked nfs-utils sources.
-See the README file for more information.])
-fi
+AC_CONFIG_MACRO_DIR([m4])
 
 dnl If the user specified --enable-32bit, then force the C compiler
 dnl to build 32 bit binaries (gcc -m32).
@@ -42,14 +37,19 @@ test "x$U" != "x" && AC_MSG_ERROR([Compiler not ANSI compliant])
 
 AC_PROG_CC_C_O
 
+dnl Check for Augeas.
+AC_CHECK_LIB([augeas],[aug_match],,[
+       AC_MSG_ERROR([Augeas library not found])
+       ])
+
+dnl Check for functions not available in earlier versions of Augeas.
+AC_CHECK_FUNC([aug_load aug_defvar aug_defnode])
+
 dnl Check for XDR library.
 AC_CHECK_LIB([portablexdr],[xdrmem_create],[],[
        AC_SEARCH_LIBS([xdrmem_create],[rpc xdr nsl])
        ])
 
-dnl Run in subdirs.
-AC_CONFIG_SUBDIRS([nfs-utils])
-
 dnl Produce output files.
 AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_FILES([Makefile])