New commands: mkfs-b, mke2journal*, mke2fs-J*
[libguestfs.git] / daemon / Makefile.am
index 7b8a87e..e6af0fe 100644 (file)
@@ -17,6 +17,8 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
+SUBDIRS = lib tests .
+
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
        actions.h \
@@ -35,17 +37,22 @@ guestfsd_SOURCES = \
        dropcaches.c \
        du.c \
        ext2.c \
+       fallocate.c \
        file.c \
        find.c \
        fsck.c \
        glob.c \
+       grep.c \
        grub.c \
        guestfsd.c \
        headtail.c \
        hexdump.c \
        initrd.c \
+       inotify.c \
+       link.c \
        ls.c \
        lvm.c \
+       mkfs.c \
        mknod.c \
        mount.c \
        names.c \
@@ -53,7 +60,9 @@ guestfsd_SOURCES = \
        pingdaemon.c \
        proto.c \
        readdir.c \
+       realpath.c \
        scrub.c \
+       selinux.c \
        sfdisk.c \
        sleep.c \
        stat.c \
@@ -71,4 +80,6 @@ guestfsd_SOURCES = \
        $(top_builddir)/../src/guestfs_protocol.h \
        $(top_builddir)/../src/guestfs_protocol.c
 
+AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
 guestfsd_CFLAGS = -Wall
+LDADD = lib/libgnu.a