New commands: mkfs-b, mke2journal*, mke2fs-J*
[libguestfs.git] / daemon / Makefile.am
index 024c097..e6af0fe 100644 (file)
@@ -17,6 +17,8 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
+SUBDIRS = lib tests .
+
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
        actions.h \
@@ -50,6 +52,7 @@ guestfsd_SOURCES = \
        link.c \
        ls.c \
        lvm.c \
+       mkfs.c \
        mknod.c \
        mount.c \
        names.c \
@@ -59,6 +62,7 @@ guestfsd_SOURCES = \
        readdir.c \
        realpath.c \
        scrub.c \
+       selinux.c \
        sfdisk.c \
        sleep.c \
        stat.c \
@@ -76,4 +80,6 @@ guestfsd_SOURCES = \
        $(top_builddir)/../src/guestfs_protocol.h \
        $(top_builddir)/../src/guestfs_protocol.c
 
+AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
 guestfsd_CFLAGS = -Wall
+LDADD = lib/libgnu.a