virt-cat: Remove some unused Perl module includes.
[libguestfs.git] / daemon / Makefile.am
index 024c097..ae74699 100644 (file)
@@ -17,6 +17,8 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
+SUBDIRS = lib tests .
+
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
        actions.h \
@@ -34,6 +36,7 @@ guestfsd_SOURCES = \
        dmesg.c \
        dropcaches.c \
        du.c \
+       echo_daemon.c \
        ext2.c \
        fallocate.c \
        file.c \
@@ -50,7 +53,9 @@ guestfsd_SOURCES = \
        link.c \
        ls.c \
        lvm.c \
+       mkfs.c \
        mknod.c \
+       modprobe.c \
        mount.c \
        names.c \
        ntfs.c \
@@ -59,6 +64,7 @@ guestfsd_SOURCES = \
        readdir.c \
        realpath.c \
        scrub.c \
+       selinux.c \
        sfdisk.c \
        sleep.c \
        stat.c \
@@ -76,4 +82,7 @@ guestfsd_SOURCES = \
        $(top_builddir)/../src/guestfs_protocol.h \
        $(top_builddir)/../src/guestfs_protocol.c
 
-guestfsd_CFLAGS = -Wall
+AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
+guestfsd_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+LDADD = lib/libgnu.a