Add 'setcon', 'getcon' commands to set and get the SELinux context.
[libguestfs.git] / daemon / Makefile.am
index ecbc3c4..9406944 100644 (file)
@@ -17,6 +17,8 @@
 
 ACLOCAL_AMFLAGS = -I m4
 
+SUBDIRS = lib tests .
+
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
        actions.h \
@@ -35,6 +37,7 @@ guestfsd_SOURCES = \
        dropcaches.c \
        du.c \
        ext2.c \
+       fallocate.c \
        file.c \
        find.c \
        fsck.c \
@@ -45,6 +48,8 @@ guestfsd_SOURCES = \
        headtail.c \
        hexdump.c \
        initrd.c \
+       inotify.c \
+       link.c \
        ls.c \
        lvm.c \
        mknod.c \
@@ -54,7 +59,9 @@ guestfsd_SOURCES = \
        pingdaemon.c \
        proto.c \
        readdir.c \
+       realpath.c \
        scrub.c \
+       selinux.c \
        sfdisk.c \
        sleep.c \
        stat.c \
@@ -72,4 +79,6 @@ guestfsd_SOURCES = \
        $(top_builddir)/../src/guestfs_protocol.h \
        $(top_builddir)/../src/guestfs_protocol.c
 
+AM_CPPFLAGS = -I$(srcdir)/lib -Ilib
 guestfsd_CFLAGS = -Wall
+LDADD = lib/libgnu.a