Document that ntfsresize cannot be used multiple times (RHBZ#685009).
[libguestfs.git] / daemon / Makefile.am
index ee1959f..78049c9 100644 (file)
@@ -45,13 +45,12 @@ BUILT_SOURCES = \
 EXTRA_DIST = $(BUILT_SOURCES) \
        .gitignore
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
 noinst_LIBRARIES = libprotocol.a
-libprotocol_a_SOURCES = \
-       guestfs_protocol.c \
-       guestfs_protocol.h
-libprotocol_a_CFLAGS =
+
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_a_SOURCES = guestfs_protocol.c guestfs_protocol.h
+libprotocol_a_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
 
 guestfs_protocol.c: $(libsrcdir)/guestfs_protocol.c
        rm -f $@
@@ -89,6 +88,7 @@ errnostring.h: $(libsrcdir)/errnostring.h
 
 noinst_PROGRAMS = guestfsd
 guestfsd_SOURCES = \
+       9p.c \
        actions.h \
        available.c \
        augeas.c \