Add caution subdirectory containing safety and liveness tests.
[libguestfs.git] / caution / Makefile.am
diff --git a/caution/Makefile.am b/caution/Makefile.am
new file mode 100644 (file)
index 0000000..f87884f
--- /dev/null
@@ -0,0 +1,36 @@
+# libguestfs
+# Copyright (C) 2011 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+# Safety and liveness tests of components that libguestfs depends upon
+# (not of libguestfs itself).  Mainly this is for qemu and the kernel.
+#
+# See also capitests and regressions directories.
+
+include $(top_srcdir)/subdir-rules.mk
+
+TESTS = \
+       qemu-snapshot-isolation.sh
+
+random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
+
+TESTS_ENVIRONMENT = \
+       MALLOC_PERTURB_=$(random_val) \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
+
+EXTRA_DIST = \
+       $(TESTS)