fish: Add man page section on calling guestfish remote robustly from bash.
[libguestfs.git] / cat / Makefile.am
index d7bc7e8..91abfac 100644 (file)
 include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
-       run-cat-locally \
        test-virt-cat.sh \
        virt-cat.pod \
-       run-filesystems-locally \
        test-virt-filesystems.sh \
        virt-filesystems.pod \
-       run-ls-locally \
        test-virt-ls.sh \
        virt-ls.pod
 
@@ -45,6 +42,7 @@ virt_cat_SOURCES = \
        virt-cat.c
 
 virt_cat_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -62,6 +60,7 @@ virt_filesystems_SOURCES = \
        virt-filesystems.c
 
 virt_filesystems_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -79,6 +78,7 @@ virt_ls_SOURCES = \
        virt-ls.c
 
 virt_ls_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -102,7 +102,7 @@ noinst_DATA = \
 virt-cat.1 $(top_builddir)/html/virt-cat.1.html: stamp-virt-cat.pod
 
 stamp-virt-cat.pod: virt-cat.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-cat.1 \
          --html $(top_builddir)/html/virt-cat.1.html \
          $<
@@ -111,7 +111,7 @@ stamp-virt-cat.pod: virt-cat.pod
 virt-ls.1 $(top_builddir)/html/virt-ls.1.html: stamp-virt-ls.pod
 
 stamp-virt-ls.pod: virt-ls.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-ls.1 \
          --html $(top_builddir)/html/virt-ls.1.html \
          $<
@@ -120,7 +120,7 @@ stamp-virt-ls.pod: virt-ls.pod
 virt-filesystems.1 $(top_builddir)/html/virt-filesystems.1.html: stamp-virt-filesystems.pod
 
 stamp-virt-filesystems.pod: virt-filesystems.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-filesystems.1 \
          --html $(top_builddir)/html/virt-filesystems.1.html \
          $<
@@ -133,6 +133,7 @@ random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
 TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 TESTS = test-virt-cat.sh test-virt-filesystems.sh test-virt-ls.sh