capitests: Remove warning about dead definitions.
[libguestfs.git] / capitests / Makefile.am
index 1dded1e..b1b4e1d 100644 (file)
@@ -26,6 +26,7 @@ EXTRA_DIST = $(BUILT_SOURCES)
 check_PROGRAMS = \
        tests \
        test-command \
+       test-just-header \
        test-create-handle \
        test-config \
        test-add-drive-opts \
@@ -33,10 +34,19 @@ check_PROGRAMS = \
 
 TESTS = \
        tests \
+       test-just-header \
        test-create-handle \
        test-config \
        test-add-drive-opts \
        test-last-errno
+
+# The API behind this test is not baked yet.
+#if HAVE_LIBVIRT
+#check_PROGRAMS += test-add-libvirt-dom
+#TESTS += test-add-libvirt-dom
+#endif
+EXTRA_DIST += test-add-libvirt-dom.c
+
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
@@ -57,6 +67,13 @@ test_command_LDFLAGS = -all-static
 
 # Hand-written C API tests.
 
+test_just_header_SOURCES = test-just-header.c
+test_just_header_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_just_header_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
 test_create_handle_SOURCES = test-create-handle.c
 test_create_handle_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
@@ -85,6 +102,17 @@ test_last_errno_CFLAGS = \
 test_last_errno_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+#if HAVE_LIBVIRT
+#test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
+#test_add_libvirt_dom_CFLAGS = \
+#      -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
+#      $(LIBVIRT_CFLAGS) \
+#      $(WARN_CFLAGS) $(WERROR_CFLAGS)
+#test_add_libvirt_dom_LDADD = \
+#      $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
+#      $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+#endif
+
 # Run the tests under valgrind.
 
 valgrind: