build: Set TMPDIR for local testing.
[libguestfs.git] / capitests / Makefile.am
index 487a33f..9802a06 100644 (file)
@@ -32,6 +32,7 @@ check_PROGRAMS = \
        test-add-drive-opts \
        test-last-errno \
        test-private-data \
+       test-user-cancel \
        test-debug-to-file
 
 TESTS = \
@@ -42,6 +43,7 @@ TESTS = \
        test-add-drive-opts \
        test-last-errno \
        test-private-data \
+       test-user-cancel \
        test-debug-to-file
 
 # The API behind this test is not baked yet.
@@ -55,6 +57,7 @@ TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir) \
        $(VG)
 
 #SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi)
@@ -114,6 +117,14 @@ test_private_data_CFLAGS = \
 test_private_data_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+test_user_cancel_SOURCES = test-user-cancel.c
+test_user_cancel_CFLAGS = \
+       -pthread \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_user_cancel_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
 test_debug_to_file_SOURCES = test-debug-to-file.c
 test_debug_to_file_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \