capitests: Add the code to test (proposed) add-libvirt-dom C API.
[libguestfs.git] / capitests / Makefile.am
index 435b1ee..95afa53 100644 (file)
@@ -28,13 +28,23 @@ check_PROGRAMS = \
        test-command \
        test-create-handle \
        test-config \
-       test-add-drive-opts
+       test-add-drive-opts \
+       test-last-errno
 
 TESTS = \
        tests \
        test-create-handle \
        test-config \
-       test-add-drive-opts
+       test-add-drive-opts \
+       test-last-errno
+
+# The API behind this test is not baked yet.
+#if HAVE_LIBVIRT
+#check_PROGRAMS += test-add-libvirt-dom
+#TESTS += test-add-libvirt-dom
+#endif
+EXTRA_DIST += test-add-libvirt-dom.c
+
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
@@ -76,6 +86,24 @@ test_add_drive_opts_CFLAGS = \
 test_add_drive_opts_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+test_last_errno_SOURCES = test-last-errno.c
+test_last_errno_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_last_errno_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
+if HAVE_LIBVIRT
+test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
+test_add_libvirt_dom_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
+       $(LIBVIRT_CFLAGS) \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_add_libvirt_dom_LDADD = \
+       $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
+       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+endif
+
 # Run the tests under valgrind.
 
 valgrind: