Add user cancellation to the C API.
[libguestfs.git] / capitests / Makefile.am
index 83e62c8..7e35872 100644 (file)
@@ -31,7 +31,9 @@ check_PROGRAMS = \
        test-config \
        test-add-drive-opts \
        test-last-errno \
-       test-private-data
+       test-private-data \
+       test-user-cancel \
+       test-debug-to-file
 
 TESTS = \
        tests \
@@ -40,7 +42,9 @@ TESTS = \
        test-config \
        test-add-drive-opts \
        test-last-errno \
-       test-private-data
+       test-private-data \
+       test-user-cancel \
+       test-debug-to-file
 
 # The API behind this test is not baked yet.
 #if HAVE_LIBVIRT
@@ -112,6 +116,23 @@ test_private_data_CFLAGS = \
 test_private_data_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
+test_user_cancel_SOURCES = test-user-cancel.c
+test_user_cancel_CFLAGS = \
+       -pthread \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_user_cancel_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
+test_debug_to_file_SOURCES = test-debug-to-file.c
+test_debug_to_file_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/gnulib/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_debug_to_file_LDADD = \
+       $(top_builddir)/src/libguestfs.la \
+       ../gnulib/lib/libgnu.la
+
 #if HAVE_LIBVIRT
 #test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
 #test_add_libvirt_dom_CFLAGS = \