Add user cancellation to the C API.
[libguestfs.git] / capitests / Makefile.am
index 0d18eaf..7e35872 100644 (file)
@@ -30,7 +30,10 @@ check_PROGRAMS = \
        test-create-handle \
        test-config \
        test-add-drive-opts \
-       test-last-errno
+       test-last-errno \
+       test-private-data \
+       test-user-cancel \
+       test-debug-to-file
 
 TESTS = \
        tests \
@@ -38,7 +41,10 @@ TESTS = \
        test-create-handle \
        test-config \
        test-add-drive-opts \
-       test-last-errno
+       test-last-errno \
+       test-private-data \
+       test-user-cancel \
+       test-debug-to-file
 
 # The API behind this test is not baked yet.
 #if HAVE_LIBVIRT
@@ -50,10 +56,11 @@ EXTRA_DIST += test-add-libvirt-dom.c
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
-       SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
        $(VG)
 
+#SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi)
+
 tests_SOURCES = tests.c
 tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
@@ -102,16 +109,40 @@ test_last_errno_CFLAGS = \
 test_last_errno_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
-if HAVE_LIBVIRT
-test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
-test_add_libvirt_dom_CFLAGS = \
-       -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
-       $(LIBVIRT_CFLAGS) \
+test_private_data_SOURCES = test-private-data.c
+test_private_data_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
-test_add_libvirt_dom_LDADD = \
-       $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
-       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
-endif
+test_private_data_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
+test_user_cancel_SOURCES = test-user-cancel.c
+test_user_cancel_CFLAGS = \
+       -pthread \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_user_cancel_LDADD = \
+       $(top_builddir)/src/libguestfs.la
+
+test_debug_to_file_SOURCES = test-debug-to-file.c
+test_debug_to_file_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/gnulib/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_debug_to_file_LDADD = \
+       $(top_builddir)/src/libguestfs.la \
+       ../gnulib/lib/libgnu.la
+
+#if HAVE_LIBVIRT
+#test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
+#test_add_libvirt_dom_CFLAGS = \
+#      -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
+#      $(LIBVIRT_CFLAGS) \
+#      $(WARN_CFLAGS) $(WERROR_CFLAGS)
+#test_add_libvirt_dom_LDADD = \
+#      $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
+#      $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+#endif
 
 # Run the tests under valgrind.