Add guestfs_add_domain 'live' flag.
[libguestfs.git] / capitests / Makefile.am
index 0d18eaf..542c4fb 100644 (file)
@@ -50,10 +50,11 @@ EXTRA_DIST += test-add-libvirt-dom.c
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
        SKIP_TEST_COMMAND_LINES=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
-       SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
        $(VG)
 
+#SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi)
+
 tests_SOURCES = tests.c
 tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
@@ -102,16 +103,16 @@ test_last_errno_CFLAGS = \
 test_last_errno_LDADD = \
        $(top_builddir)/src/libguestfs.la
 
-if HAVE_LIBVIRT
-test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
-test_add_libvirt_dom_CFLAGS = \
-       -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
-       $(LIBVIRT_CFLAGS) \
-       $(WARN_CFLAGS) $(WERROR_CFLAGS)
-test_add_libvirt_dom_LDADD = \
-       $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
-       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
-endif
+#if HAVE_LIBVIRT
+#test_add_libvirt_dom_SOURCES = test-add-libvirt-dom.c
+#test_add_libvirt_dom_CFLAGS = \
+#      -I$(top_srcdir)/src -I$(top_builddir)/src -I$(top_srcdir)/gnulib/lib \
+#      $(LIBVIRT_CFLAGS) \
+#      $(WARN_CFLAGS) $(WERROR_CFLAGS)
+#test_add_libvirt_dom_LDADD = \
+#      $(top_builddir)/src/libguestfs.la $(LIBVIRT_LIBS) \
+#      $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+#endif
 
 # Run the tests under valgrind.