use STREQ, not strcmp: part 1
[libguestfs.git] / capitests / Makefile.am
index ab91755..3b80c0e 100644 (file)
@@ -24,9 +24,18 @@ EXTRA_DIST = \
 check_PROGRAMS = tests test-command
 
 tests_SOURCES = tests.c
-tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src -Wall
+tests_CFLAGS = -I$(top_srcdir)/src -I$(top_builddir)/src \
+  $(WARN_CFLAGS) $(WERROR_CFLAGS)
 tests_LDADD = $(top_builddir)/src/libguestfs.la
 
+# Old version of e2fsprogs which didn't support UUIDs?
+e2fs_uuid_not_supported :=                                              \
+  $(shell r=1;                                                          \
+    test -x ../initramfs/sbin/mkswap                                    \
+      && ../initramfs/sbin/mkswap --help 2>&1 | grep -sq -- -U          \
+      && r=1;                                                           \
+    echo $$r)
+
 TESTS = tests
 TESTS_ENVIRONMENT = \
        SKIP_TEST_COMMAND=$(shell ldd test-command | grep -sq 'not a dynamic executable' || echo 1) \
@@ -34,6 +43,11 @@ TESTS_ENVIRONMENT = \
        SKIP_TEST_ZEROFREE=$(shell test -x ../initramfs/usr/sbin/zerofree || echo 1) \
        SKIP_TEST_NTFS_3G_PROBE=$(shell test -x ../initramfs/bin/ntfs-3g.probe || echo 1) \
        SKIP_TEST_CHECKSUM_8=$(shell if test `find ../initramfs -name squashfs.ko | wc -l` -eq 0; then echo 1; fi) \
+       SKIP_TEST_MKSWAP_U=$(e2fs_uuid_not_supported) \
+       SKIP_TEST_SWAPON_UUID=$(e2fs_uuid_not_supported) \
+       SKIP_TEST_MKE2JOURNAL_U=$(e2fs_uuid_not_supported) \
+       SKIP_TEST_SCRUB_FILE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
+       SKIP_TEST_SCRUB_DEVICE=$(shell test -x ../initramfs/usr/bin/scrub || echo 1) \
        $(VG)
 
 # Run the tests under valgrind.