autogen: Touch ocaml/.depend
[libguestfs.git] / bootstrap
index 2eba6a7..5ceac31 100755 (executable)
--- a/bootstrap
+++ b/bootstrap
@@ -29,20 +29,14 @@ GNULIB_SRCDIR=.gnulib
 ls po/*.po 2>/dev/null | sed 's|.*/||; s|\.po$||' > po/LINGUAS
 
 # Run autopoint, to get po/Makevars.template:
-autopoint
+# Also, released autopoint has the tendency to install macros that have
+# been obsoleted in current gnulib, so run this before gnulib-tool.
+autopoint --force
 
-# Create gettext configuration.
-echo "$0: Creating po/Makevars from po/Makevars.template ..."
-rm -f po/Makevars
-sed '
-  /^EXTRA_LOCALE_CATEGORIES *=/s/=.*/= '"$EXTRA_LOCALE_CATEGORIES"'/
-  /^MSGID_BUGS_ADDRESS *=/s/=.*/= '"$MSGID_BUGS_ADDRESS"'/
-  /^XGETTEXT_OPTIONS *=/{
-    s/$/ \\/
-    a\
-        '"$XGETTEXT_OPTIONS"' $${end_of_xgettext_options+}
-  }
-' po/Makevars.template >po/Makevars
+# Autoreconf runs aclocal before libtoolize, which causes spurious
+# warnings if the initial aclocal is confused by the libtoolized
+# (or worse out-of-date) macro directory.
+libtoolize --copy --install
 
 gnulib_tool=$GNULIB_SRCDIR/gnulib-tool
 <$gnulib_tool || exit
@@ -50,27 +44,50 @@ gnulib_tool=$GNULIB_SRCDIR/gnulib-tool
 (cd daemon && mkdir -p tests lib && ../$gnulib_tool --update)
 
 modules='
-asprintf
+arpa_inet
+c-ctype
 closeout
+error
+filevercmp
+fts
+full-read
+full-write
 gitlog-to-changelog
 gnu-make
 gnumakefile
+hash
+hash-pjw
 ignore-value
+lock
 maintainer-makefile
 manywarnings
+netinet_in
 progname
+setenv
 strchrnul
 strerror
 strndup
 vasprintf
 vc-list-files
 warnings
+xalloc
+xalloc-die
+xstrtol
+xstrtoll
+xvasprintf
 '
 
 $gnulib_tool                   \
   --avoid=dummy                        \
   --with-tests                 \
-  --m4-base=gnulib/m4          \
+  --m4-base=m4                 \
   --source-base=gnulib/lib     \
   --tests-base=gnulib/tests    \
   --import $modules
+
+# ocaml/.depend is updated automatically. However, as it's included by
+# ocaml/Makefile.am we need to bootstrap it here.
+touch ocaml/.depend
+
+# Disable autopoint and libtoolize, since they were already done above.
+AUTOPOINT=true LIBTOOLIZE=true autoreconf --verbose --install