daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / appliance / Makefile.am
index 503160e..e2e8b96 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -69,6 +69,7 @@ supermin.d/daemon.img: ../daemon/guestfsd
        mv $@-t $@
 
 supermin.d/init.img: init
+       cmp -s $(srcdir)/init $(builddir)/init || cp $(srcdir)/init $(builddir)/init
        mkdir -p supermin.d
        rm -f $@ $@-t
        echo "init" | cpio --quiet -o -H newc > $@-t