Generated code for 'sh' and 'sh-lines' commands.
[libguestfs.git] / appliance / Makefile.am
index 2c8a0be..d692c7f 100644 (file)
 
 EXTRA_DIST = \
        make.sh update.sh supermin-split.sh supermin-make.sh \
-       guestfs-supermin-helper \
+       libguestfs-supermin-helper \
        kmod.whitelist \
-       kmod.whitelist.in
+       kmod.whitelist.in \
+       packagelist.in \
+       init
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -38,7 +40,7 @@ fs_DATA = $(APPLIANCE_FILES)
 APPLIANCE_FILES = $(INITRAMFSIMG) $(VMLINUZ)
 if SUPERMIN
 APPLIANCE_FILES += $(SUPERMINIMG) $(SUPERMINFILES) kmod.whitelist
-bin_SCRIPTS = guestfs-supermin-helper
+bin_SCRIPTS = libguestfs-supermin-helper
 endif
 
 # Don't change these names - they must be the same as in '*.sh' scripts.
@@ -52,7 +54,7 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
        -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
        -mv $(VMLINUZ) $(VMLINUZ).bak
        if ! bash make.sh; then rm -f $@; exit 1; fi
@@ -65,6 +67,10 @@ $(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/g
 kmod.whitelist: kmod.whitelist.in
        grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
 
+packagelist: packagelist.in
+       cpp -undef -DREDHAT=1 < $< | \
+       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
+
 # This is for building the supermin appliance.  It has to be enabled
 # specifically with './configure --enable-supermin'.  You really need
 # to read the README file.
@@ -92,7 +98,7 @@ endif
        cd .. && ./config.status appliance/$@
        chmod +x $@
 
-guestfs-supermin-helper: guestfs-supermin-helper.in
+libguestfs-supermin-helper: libguestfs-supermin-helper.in
        cd .. && ./config.status appliance/$@
        chmod +x $@