out-of-tree build: fix appliance
[libguestfs.git] / appliance / Makefile.am
index bbf3c24..bec2b48 100644 (file)
 include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
-       kmod.whitelist.in \
        packagelist.in \
+       excludelist.in \
        init \
-       debian/modules/y0_install-guestfsd \
-       debian/modules/z99_final-cleanups \
-       debian/debirf.conf.in \
        make.sh.in
 
-# Build the root filesystem (appliance).
-# Currently this is arch-dependent, so it seems like putting it in
-# $(libdir) is best.  When we build cross-architecture filesystems we
-# should probably move them to $(datadir).
 fsdir = $(libdir)/guestfs
 superminfsdir = $(libdir)/guestfs/supermin.d
 
-# These are the resulting output files from the whole process:
-#   VMLINUZ        kernel for the full appliance
-#   INITRAMFSIMG   initramfs (ie. root fs) for the full appliance
-# For details of the supermin appliance, read the README file.
-fs_DATA = $(INITRAMFSIMG) $(VMLINUZ)
-if SUPERMIN
-fs_DATA += kmod.whitelist
+fs_DATA =
 superminfs_DATA = \
        supermin.d/base.img \
        supermin.d/daemon.img \
+       supermin.d/init.img \
        supermin.d/hostfiles
-endif
-
-# Don't change these names - they must be the same as in '*.sh' scripts.
-INITRAMFSIMG = initramfs.$(REPO).$(host_cpu).img
-VMLINUZ = vmlinuz.$(REPO).$(host_cpu)
-
-# This is for building the normal appliance:
-$(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
-
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist $(top_builddir)/daemon/guestfsd
-       mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
-       mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
-       if ! bash make.sh; then rm -f $@; exit 1; fi
 
 # This used to be a configure-generated file (as is update.sh still).
 # However config.status always touches the destination file, which
@@ -67,62 +42,42 @@ make.sh: make.sh.in
        chmod +x $@-t
        mv $@-t $@
 
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
-       rm -f $@
-       bash update.sh
-       touch $@
-
-kmod.whitelist: kmod.whitelist.in
-       grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
-
 packagelist: packagelist.in
-       cpp -undef -D$(DIST)=1 < $< | \
-       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
-
-# This is for building the supermin appliance.  It has to be enabled
-# specifically with './configure --enable-supermin'.  You really need
-# to read the README file.
+       cpp -undef -D$(DISTRO)=1 < $< | \
+       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@-t
+       mv $@-t $@
 
-if SUPERMIN
+excludelist: excludelist.in
+       cpp -undef -D$(DISTRO)=1 < $< | \
+       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@-t
+       mv $@-t $@
 
 supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: $(INITRAMFSIMG)
+stamp-supermin: make.sh packagelist excludelist
        mkdir -p supermin.d
        rm -f $@ supermin.d/base.img supermin.d/hostfiles
-       febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
-       if grep -q /usr/share/augeas/lenses supermin.d/hostfiles; then \
-               echo "./usr/share/augeas/lenses/*.aug" >> supermin.d/hostfiles; \
-       fi
+       ./make.sh
        touch $@
 
-supermin.d/daemon.img: $(INITRAMFSIMG)
+supermin.d/daemon.img: ../daemon/guestfsd
        mkdir -p supermin.d
        rm -f $@ $@-t
-       (cd $(top_builddir)/initramfs && \
-         echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc ) > $@-t
+       mkdir sbin
+       cd sbin && ln ../../daemon/guestfsd
+       echo -e "sbin\nsbin/guestfsd" | cpio --quiet -o -H newc > $@-t
+       rm -r sbin
        mv $@-t $@
-endif
 
-# Extra symlinks needed by the Debian appliance.
-debirf_symlinks = \
-       a0_prep-root \
-       install-kernel \
-       z0_remove-aptitude \
-       z0_remove-locales \
-       z1_clean-root
-noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
-$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
-stamp-debirf-modules:
-       mkdir -p debian/modules
-       for f in $(debirf_symlinks); do \
-         ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
-       done
-       touch $@
+supermin.d/init.img: init
+       cmp -s $(srcdir)/init $(builddir)/init || cp $(srcdir)/init $(builddir)/init
+       mkdir -p supermin.d
+       rm -f $@ $@-t
+       echo "init" | cpio --quiet -o -H newc > $@-t
+       mv $@-t $@
 
 # Make clean.
 
-CLEANFILES = packagelist kmod.whitelist
+CLEANFILES = packagelist excludelist
 
 clean-local:
-       rm -f supermin.d/*
-       rm -rf $(top_builddir)/initramfs
+       rm -rf supermin.d