Ubuntu: Use apt-get instead of aptitude when installing guestfsd.
[libguestfs.git] / appliance / Makefile.am
index 157c875..77f40d2 100644 (file)
@@ -87,13 +87,13 @@ packagelist: packagelist.in
 if SUPERMIN
 
 supermin.d/base.img supermin.d/hostfiles: stamp-supermin
-stamp-supermin: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/initramfs/init
+stamp-supermin: $(INITRAMFSIMG)
        mkdir -p supermin.d
        rm -f $@ supermin.d/base.img supermin.d/hostfiles
        febootstrap-to-supermin $(top_builddir)/initramfs supermin.d/base.img supermin.d/hostfiles
        touch $@
 
-supermin.d/daemon.img: $(top_builddir)/initramfs/sbin/guestfsd
+supermin.d/daemon.img: $(INITRAMFSIMG)
        mkdir -p supermin.d
        rm -f $@ $@-t
        (cd $(top_builddir)/initramfs && \
@@ -104,6 +104,7 @@ endif
 # Extra symlinks needed by the Debian appliance.
 debirf_symlinks = \
        a0_prep-root \
+       install-kernel \
        z0_remove-aptitude \
        z0_remove-locales \
        z1_clean-root