Added 'scrub-*' commands for securely scrubbing filesystems.
[libguestfs.git] / appliance / Makefile.am
index 883bda5..74157b0 100644 (file)
@@ -19,7 +19,9 @@ EXTRA_DIST = \
        make.sh update.sh supermin-split.sh supermin-make.sh \
        libguestfs-supermin-helper \
        kmod.whitelist \
-       kmod.whitelist.in
+       kmod.whitelist.in \
+       packagelist.in \
+       init
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -52,7 +54,7 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
        -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
        -mv $(VMLINUZ) $(VMLINUZ).bak
        if ! bash make.sh; then rm -f $@; exit 1; fi
@@ -65,6 +67,10 @@ $(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/g
 kmod.whitelist: kmod.whitelist.in
        grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
 
+packagelist: packagelist.in
+       cpp -undef -DREDHAT=1 < $< | \
+       grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
+
 # This is for building the supermin appliance.  It has to be enabled
 # specifically with './configure --enable-supermin'.  You really need
 # to read the README file.
@@ -74,7 +80,7 @@ if SUPERMIN
 # First we need to decide which files go in and out of the supermin
 # appliance.  This decision is made by 'supermin-split.sh'.
 $(SUPERMINFILES): supermin.incfiles
-supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log supermin-split.sh
+supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd supermin-split.sh
        rm -f supermin.incfiles $(SUPERMINFILES)
        bash supermin-split.sh
 
@@ -120,7 +126,7 @@ test-boot-realistic: emptydisk
          -m 384 \
          -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
          -hda emptydisk \
-         -append "console=ttyS0 guestfs=10.0.2.4:6666" \
+         -append "console=ttyS0 guestfs=10.0.2.4:6666 guestfs_rescue=1" \
          -nographic \
          -serial stdio \
          -net channel,6666:unix:/tmp/sock,server,nowait \