test-boot-realistic rule should boot the rescue shell.
[libguestfs.git] / appliance / Makefile.am
index 4f5eeee..74157b0 100644 (file)
@@ -20,7 +20,8 @@ EXTRA_DIST = \
        libguestfs-supermin-helper \
        kmod.whitelist \
        kmod.whitelist.in \
-       packagelist.in
+       packagelist.in \
+       init
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -53,7 +54,7 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
        -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
        -mv $(VMLINUZ) $(VMLINUZ).bak
        if ! bash make.sh; then rm -f $@; exit 1; fi
@@ -79,7 +80,7 @@ if SUPERMIN
 # First we need to decide which files go in and out of the supermin
 # appliance.  This decision is made by 'supermin-split.sh'.
 $(SUPERMINFILES): supermin.incfiles
-supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log supermin-split.sh
+supermin.incfiles: $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd supermin-split.sh
        rm -f supermin.incfiles $(SUPERMINFILES)
        bash supermin-split.sh
 
@@ -125,7 +126,7 @@ test-boot-realistic: emptydisk
          -m 384 \
          -kernel $(VMLINUZ) -initrd $(INITRAMFSIMG) \
          -hda emptydisk \
-         -append "console=ttyS0 guestfs=10.0.2.4:6666" \
+         -append "console=ttyS0 guestfs=10.0.2.4:6666 guestfs_rescue=1" \
          -nographic \
          -serial stdio \
          -net channel,6666:unix:/tmp/sock,server,nowait \