Use link-local addresses between appliance and host (RHBZ#588763).
[libguestfs.git] / appliance / Makefile.am
index e2b0b31..27a23d3 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 EXTRA_DIST = \
-       make.sh update.sh supermin-split.sh supermin-make.sh \
-       libguestfs-supermin-helper \
-       kmod.whitelist \
        kmod.whitelist.in \
        packagelist.in \
        init \
        debian/modules/install_kernel \
        debian/modules/y0_install-guestfsd \
        debian/modules/z99_final-cleanups \
-       debian/debirf.conf.in
+       debian/debirf.conf.in \
+       make.sh.in
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -44,7 +44,14 @@ fs_DATA = $(APPLIANCE_FILES)
 APPLIANCE_FILES = $(INITRAMFSIMG) $(VMLINUZ)
 if SUPERMIN
 APPLIANCE_FILES += $(SUPERMINIMG) $(SUPERMINFILES) kmod.whitelist
-bin_SCRIPTS = libguestfs-supermin-helper
+bin_PROGRAMS = libguestfs-supermin-helper
+libguestfs_supermin_helper_SOURCES = \
+       libguestfs-supermin-helper.c ../gnulib/lib/xalloc-die.c
+libguestfs_supermin_helper_CFLAGS = \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+libguestfs_supermin_helper_LDADD = \
+       ../gnulib/lib/libgnu.la
 endif
 
 # Don't change these names - they must be the same as in '*.sh' scripts.
@@ -58,11 +65,20 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
-       -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
-       -mv $(VMLINUZ) $(VMLINUZ).bak
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist $(top_builddir)/daemon/guestfsd
+       mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak 2>/dev/null; :
+       mv $(VMLINUZ) $(VMLINUZ).bak 2>/dev/null; :
        if ! bash make.sh; then rm -f $@; exit 1; fi
 
+# This used to be a configure-generated file (as is update.sh still).
+# However config.status always touches the destination file, which
+# means the appliance got rebuilt too often.
+make.sh: make.sh.in
+       cd $(top_builddir) && \
+         ./config.status --file=appliance/$@-t:appliance/$<
+       chmod +x $@-t
+       mv $@-t $@
+
 $(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
        rm -f $@
        bash update.sh
@@ -105,6 +121,7 @@ debirf_symlinks = \
 noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
 $(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
 stamp-debirf-modules:
+       mkdir -p debian/modules
        for f in $(debirf_symlinks); do \
          ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
        done
@@ -143,8 +160,7 @@ test-boot-realistic: emptydisk
 
 # Make clean.
 
-CLEANFILES = $(APPLIANCE_FILES)
+CLEANFILES = $(APPLIANCE_FILES) packagelist kmod.whitelist supermin.incfiles
 
 clean-local:
        rm -rf $(top_builddir)/initramfs
-