Miscellaneous fixes for non-srcdir builds.
[libguestfs.git] / appliance / Makefile.am
index 74157b0..17a49d7 100644 (file)
@@ -21,7 +21,11 @@ EXTRA_DIST = \
        kmod.whitelist \
        kmod.whitelist.in \
        packagelist.in \
-       init
+       init \
+       debian/modules/install_kernel \
+       debian/modules/y0_install-guestfsd \
+       debian/modules/z99_final-cleanups \
+       debian/debirf.conf.in
 
 # Build the root filesystem (appliance).
 # Currently this is arch-dependent, so it seems like putting it in
@@ -54,12 +58,12 @@ endif
 # This is for building the normal appliance:
 $(INITRAMFSIMG) $(VMLINUZ): $(top_builddir)/initramfs/fakeroot.log
 
-$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist init
+$(top_builddir)/initramfs/fakeroot.log: make.sh kmod.whitelist packagelist
        -mv $(INITRAMFSIMG) $(INITRAMFSIMG).bak
        -mv $(VMLINUZ) $(VMLINUZ).bak
        if ! bash make.sh; then rm -f $@; exit 1; fi
 
-$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd update.sh
+$(INITRAMFSIMG): $(top_builddir)/initramfs/fakeroot.log $(top_builddir)/daemon/guestfsd init update.sh
        rm -f $@
        bash update.sh
        touch $@
@@ -68,7 +72,7 @@ kmod.whitelist: kmod.whitelist.in
        grep -v '^[[:space:]]*$$' < $< | grep -v '^#' > $@
 
 packagelist: packagelist.in
-       cpp -undef -DREDHAT=1 < $< | \
+       cpp -undef -D$(DIST)=1 < $< | \
        grep -v '^[[:space:]]*$$' | grep -v '^#' > $@
 
 # This is for building the supermin appliance.  It has to be enabled
@@ -92,15 +96,20 @@ $(SUPERMINIMG): supermin.incfiles supermin-make.sh
 
 endif
 
-# This should rebuild the scripts if the input files change, although
-# it doesn't always seem to work.
-%.sh: %.sh.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
-
-libguestfs-supermin-helper: libguestfs-supermin-helper.in
-       cd .. && ./config.status appliance/$@
-       chmod +x $@
+# Extra symlinks needed by the Debian appliance.
+debirf_symlinks = \
+       a0_prep-root \
+       z0_remove-aptitude \
+       z0_remove-locales \
+       z1_clean-root
+noinst_DATA = $(debirf_symlinks:%=debian/modules/%)
+$(debirf_symlinks:%=debian/modules/%): stamp-debirf-modules
+stamp-debirf-modules:
+       mkdir -p debian/modules
+       for f in $(debirf_symlinks); do \
+         ln -sf /usr/share/debirf/modules/$$f debian/modules/$$f; \
+       done
+       touch $@
 
 #----------------------------------------------------------------------
 # Extra rules for testing the appliance.
@@ -135,7 +144,7 @@ test-boot-realistic: emptydisk
 
 # Make clean.
 
-CLEANFILES = $(APPLIANCE_FILES)
+CLEANFILES = $(APPLIANCE_FILES) packagelist kmod.whitelist
 
 clean-local:
        rm -rf $(top_builddir)/initramfs