hivex: Added gnulib includes from builddir, as suggested by the Gnulib documentation...
[hivex.git] / lib / Makefile.am
index 75db8bf..a339a00 100644 (file)
@@ -1,5 +1,5 @@
 # hivex
-# Copyright (C) 2009-2010 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 SUBDIRS = tools
 
 EXTRA_DIST = \
-       hivex.pod
+       hivex.pod \
+       hivex.syms
 
 lib_LTLIBRARIES = libhivex.la
 
 libhivex_la_SOURCES = \
   hivex.c \
   hivex.h \
+  hivex-internal.h \
   byte_conversions.h \
-  gettext.h
+  gettext.h \
+  mmap.h \
+  hivex.syms
 
-libhivex_la_LIBADD =  ../gnulib/lib/libgnu.la
-libhivex_la_LDFLAGS = -version-info 0:0:0 $(LTLIBINTL) $(LTLIBTHREAD)
+libhivex_la_LIBADD =  ../gnulib/lib/libgnu.la $(LTLIBOBJS)
+libhivex_la_LDFLAGS = \
+       -version-info 0:0:0 \
+       $(VERSION_SCRIPT_FLAGS)$(srcdir)/hivex.syms \
+       $(LTLIBINTL) \
+       $(LTLIBTHREAD)
 libhivex_la_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
-libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
+libhivex_la_CPPFLAGS = \
+  -I$(top_srcdir)/gnulib/lib \
+  -I$(top_builddir)/gnulib/lib \
+  -I$(srcdir)
 
 include_HEADERS = hivex.h
 
@@ -50,10 +61,23 @@ noinst_DATA = \
 
 $(top_builddir)/html/hivex.3.html: hivex.pod
        mkdir -p $(top_builddir)/html
-       cd $(top_builddir) && pod2html \
-         --css 'pod.css' \
-         --htmldir html \
-         --outfile html/hivex.3.html \
-         lib/hivex.pod
+       pod2html \
+         --css pod.css \
+         --htmldir $(top_builddir)/html \
+         --outfile $(top_builddir)/html/hivex.3.html \
+         $<
 
 CLEANFILES = $(man_MANS)
+
+# Tests.
+
+check_PROGRAMS = test-just-header
+
+TESTS = test-just-header
+
+test_just_header_SOURCES = test-just-header.c
+test_just_header_CFLAGS = \
+       -I$(top_srcdir)/lib -I$(top_builddir)/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+test_just_header_LDADD = \
+       $(top_builddir)/lib/libhivex.la