initial ovirt-viewer rpm spec
[ovirt-viewer.git] / ovirt-viewer.spec
diff --git a/ovirt-viewer.spec b/ovirt-viewer.spec
new file mode 100644 (file)
index 0000000..304777d
--- /dev/null
@@ -0,0 +1,65 @@
+%define pbuild %{_builddir}/%{name}-%{version}
+
+Name: ovirt-viewer
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: ovirt-viewer is a vnc viewer for ovirt managed vms
+
+Group: Applications/System
+License: GPLv2+
+URL: http://www.ovirt.org
+
+# The source for this package was pulled from upstream's vcs.  Use the
+# following commands to generate the tarball:
+#  git clone git://ovirt.org/ovirt-viewer ovirt-viewer-1.0.0
+#  tar -czvf ovirt-viewer-1.0.0.tgz ovirt-viewer-1.0.0
+Source0: %{name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
+BuildRequires: autoconf
+BuildRequires: automake
+BuildRequires: gtk2-devel
+BuildRequires: gtk-vnc-devel
+BuildRequires: libxml2-devel
+BuildRequires: gnutls-devel
+BuildRequires: libcurl-devel
+BuildRequires: glib2-devel
+Requires: gtk2
+Requires: gtk-vnc
+Requires: libxml2
+Requires: gnutls
+Requires: libcurl
+Requires: glib2
+
+
+%description
+ovirt-viewer is a vnc viewer which integrates nicely into the ovirt
+framework. When running the program, the user is prompted for the 
+ovirt server url and login credentials, after which a list of
+accessible vms is retrieved, any of which the user may connect
+to via vnc. ovirt-viewer manages all connections on the backend and
+allows the users to seemlessly switch between managed vms via ui.
+
+%prep
+%setup -q
+
+%build
+./autogen.sh
+./configure
+make %{?_smp_mflags}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__install} -Dp -m0755 %{pbuild}/ovirt-viewer %{buildroot}%{_bindir}/ovirt-viewer
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%{_bindir}/ovirt-viewer
+
+%changelog
+* Mon Mar  16 2009  <mmorsi@redhat.com> - 1.0.0-1
+- Initial checkout and build.