add cmd line option for server vnc port
[ovirt-viewer.git] / ovirt-viewer.spec
1 %define pbuild %{_builddir}/%{name}-%{version}
2
3 Name: ovirt-viewer
4 Version: 1.0.0
5 Release: 4%{?dist}
6 Summary: ovirt-viewer is a vnc viewer for ovirt managed vms
7
8 Group: Applications/System
9 License: GPLv2+
10 URL: http://www.ovirt.org
11
12 # The source for this package was pulled from upstream's vcs.  Use the
13 # following commands to generate the tarball:
14 #  git clone git://ovirt.org/ovirt-viewer ovirt-viewer-1.0.0
15 #  tar -czvf ovirt-viewer-1.0.0.tgz ovirt-viewer-1.0.0
16 Source0: %{name}-%{version}.tgz
17
18 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
19 BuildRequires: autoconf
20 BuildRequires: automake
21 BuildRequires: gtk2-devel
22 BuildRequires: gtk-vnc-devel
23 BuildRequires: libxml2-devel
24 BuildRequires: gnutls-devel
25 BuildRequires: libcurl-devel
26 BuildRequires: glib2-devel
27 Requires: gtk2
28 Requires: gtk-vnc
29 Requires: libxml2
30 Requires: gnutls
31 Requires: libcurl
32 Requires: glib2
33
34
35 %description
36 ovirt-viewer is a vnc viewer which integrates nicely into the ovirt
37 framework. When running the program, the user is prompted for the 
38 ovirt server url and login credentials, after which a list of
39 accessible vms is retrieved, any of which the user may connect
40 to via vnc. ovirt-viewer manages all connections on the backend and
41 allows the users to seemlessly switch between managed vms via ui.
42
43 %prep
44 %setup -q
45
46 %build
47 ./autogen.sh
48 ./configure
49 make %{?_smp_mflags}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__install} -Dp -m0755 %{pbuild}/ovirt-viewer %{buildroot}%{_bindir}/ovirt-viewer
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 %{_bindir}/ovirt-viewer
62
63 %changelog
64 * Mon Jun  01 2009  <mmorsi@redhat.com> - 1.0.0-4
65 - bugfixes, dns lookup and local tunnel port assignment
66
67 * Wed May  20 2009  <mmorsi@redhat.com> - 1.0.0-3
68 - changes to viewer to connect to ovirt server
69   through vnc proxy
70
71 * Thu Apr  30 2009  <mmorsi@redhat.com> - 1.0.0-2
72 - ssl support, see check-certificate cmd line flag
73 - wire up send key menu
74 - slew of other interface / usability improvements
75
76 * Mon Mar  16 2009  <mmorsi@redhat.com> - 1.0.0-1
77 - Initial checkout and build.